mg热血羽毛球网站
北京SEO百度排名優化_刷百度排名行業領先-小度SEO一站式SEO服務,幫助企業網站快速排名,快速上首頁!
首頁

主頁 > 網絡營銷 > 華為交換機配置命令大全,先收藏起來留著以后用

華為交換機配置命令大全,先收藏起來留著以后用

首頁 2019-02-20 17:02 網絡營銷 89 ℃


華為交換機配置命令大全,先收藏起來留著以后用 互聯百科

一、單交換機VLAN劃分

system 進入系統視圖

system-view 進入系統視圖

quit 退到系統視圖

undo vlan 20 刪除vlan 20

sysname 交換機命名

disp vlan 顯示vlan

vlan 20 創建vlan(也可進入vlan 20)

port e1/0/1 to e1/0/5 把端口1-5放入VLAN 20 中

disp vlan 20 顯示vlan里的端口20

int e1/0/24 進入端口24

port access vlan 20 把當前端口放入vlan 20

undo port e1/0/10 表示刪除當前VLAN端口10

disp curr 顯示當前配置

  二、配置交換機支持TELNET

system 進入系統視圖

sysname 交換機命名

int vlan 1 進入VLAN 1

ip address 192.168.3.100 255.255.255.0 配置IP地址

user-int vty 0 4 進入虛擬終端

authentication-mode password (aut password) 設置口令模式

set authentication password simple 222 (set aut pass sim 222) 設置口令

user privilege level 3(use priv lev 3) 配置用戶級別

disp current-configuration (disp cur) 查看當前配置

disp ip int 查看交換機VLAN IP配置

刪除配置必須退到用戶模式

reset saved-configuration(reset saved) 刪除配置

reboot 重啟交換機

  三、跨交換機VLAN的通訊

在sw1上:

vlan 10 建立VLAN 10

int e1/0/5 進入端口5

port access vlan 10 把端口5加入vlan 10

vlan 20 建立VLAN 20

int e1/0/15 進入端口15

port access vlan 20 把端口15加入VLAN 20

int e1/0/24 進入端口24

port link-type trunk 把24端口設為TRUNK端口

port trunk permit vlan all 同上

在SW2上:

vlan 10 建立VLAN 10

int e1/0/20 進入端口20

port access vlan 10 把端口20放入VLAN 10

int e1/0/24 進入端口24

port link-type trunk 把24端口設為TRUNK端口

port trunk permit vlan all (port trunk permit vlan 10 只能為vlan 10使用)24端口為所有VLAN使用

disp int e1/0/24 查看端口24是否為TRUNK

undo port trunk permit vlan all 刪除該句

  四、路由的配置命令

system 進入系統模式

sysname 命名

int e1/0 進入端口

ip address 192.168.3.100 255.255.255.0 設置IP

undo shutdown 打開端口

disp ip int e1/0 查看IP接口情況

disp ip int brief 查看IP接口情況

user-int vty 0 4 進入口令模式

authentication-mode password(auth pass) 進入口令模式

set authentication password simple 222 37 設置口令

user privilege level 3 進入3級特權

save 保存配置

reset saved-configuration 刪除配置(用戶模式下運行)

undo shutdown 配置遠程登陸密碼

int e1/4

ip route 192.168.3.0(目標網段) 255.255.255.0 192.168.12.1(下一跳:下一路由器的接口) 靜態路由

ip route 0.0.0.0 0.0.0.0 192.168.12.1 默認路由

disp ip rout 顯示路由列表

華3C AR-18

E1/0(lan1-lan4)

E2/0(wan0)

E3/0(WAN1)

路由器連接使用直通線。wan0接wan0或wan1接wan1

計算機的網關應設為路由器的接口地址。

  五、三層交換機配置VLAN-VLAN通訊

sw1(三層交換機):

system 進入視圖

sysname 命名

vlan 10 建立VLAN 10

vlan 20 建立VLAN 20

int e1/0/20 進入端口20

port access vlan 10 把端口20放入VLAN 10

int e1/0/24 進入24端口

port link-type trunk 把24端口設為TRUNK端口

port trunk permit vlan all (port trunk permit vlan 10 只能為vlan 10使用)24端口為所有VLAN使用

sw2:

vlan 10

int e1/0/5

port access vlan 10

int e1/0/24

port link-type trunk 把24端口設為TRUNK端口

port trunk permit vlan all (port trunk permit vlan 10 只能為vlan 10使用)24端口為所有VLAN使用

sw1(三層交換機):

int vlan 10 創建虛擬接口VLAN 10

ip address 192.168.10.254 255.255.255.0 設置虛擬接口VLAN 10的地址

int vlan 20 創建虛擬接口VLAN 20

ip address 192.168.20.254 255.255.255.0 設置虛擬接口IP VLAN 20的地址

注意:vlan 10里的計算機的網關設為 192.168.10.254

vlan 20里的計算機的網關設為 192.168.20.254

  六、動態路由RIP

R1:

int e1/0 進入e1/0端口

ip address 192.168.3.1 255.255.255.0 設置IP

int e2/0 進入e2/0端口

ip adress 192.168.5.1 255.255.255.0 設置IP

rip 設置動態路由

network 192.168.5.0 定義IP

network 192.168.3.0 定義IP

disp ip rout 查看路由接口

R2:

int e1/0 進入e1/0端口

ip address 192.168.4.1 255.255.255.0 設置IP

int e2/0 進入e2/0端口

ip adress 192.168.5.2 255.255.255.0 設置IP

rip 設置動態路由

network 192.168.5.0 定義IP

network 192.168.4.0 定義IP

disp ip rout 查看路由接口

(注意:兩臺PC機的網關設置PC1 IP:192.168.3.1 PC2 IP:

192.168.4.1)

  七、IP訪問列表

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.168.1.1 255.255.255.0

int e3/0

ip address 192.168.2.1 255.255.255.0

acl number 2001 (2001-2999屬于基本的訪問列表)

rule 1 deny source 192.168.1.0 0.0.0.255 (拒絕地址192.168.1.0網段的數據通過)

rule 2 permit source 192.168.3.0 0.0.0.255(允許地址192.168.3.0網段的數據通過)

以下是把訪問控制列表在接口下應用:

firewall enable

firewall default permit

int e3/0

firewall packet-filter 2001 outbound

disp acl 2001 顯示信息

undo acl number 2001 刪除2001控制列表

  擴展訪問控制列表

acl number 3001

rule deny tcp source 192.168.3.0 0.0.0.255 destination 192.168.2.0 0.0.0.255 destination-port eq ftp

必須在r-acl-adv-3001下才能執行

rule permit ip source an destination any (rule permit ip)

int e3/0

firewall enable 開啟防火墻

firewall packet-filter 3001 inbound

必須在端口E3/0下才能執行

  八、命令的標準訪問IP列表(三層交換機):

允許A組機器訪問服務器內資料,不允許訪問B組機器(服務器沒有限制)

sys

vlan 10

name server

vlan 20

name teacher

vlan 30

name student

int e1/0/5

port access vlan 10

int e1/0/10

port access vlan 20

int e1/0/15

port access vlan 30

int vlan 10

ip address 192.168.10.1 255.255.255.0

undo sh

int vlan 20

ip address 192.168.20.1 255.255.255.0

int vlan 30

ip address 192.168.30.1 255.255.255.0

acl number 2001

rule 1 deny source 192.168.30.0 0.0.0.255

rule 2 permit source any

disp acl 2001 查看2001列表

int e1/0/10

port access vlan 20

packet-filter outbound ip-group 2001 rule 1

出口

  九、允許A機器訪問B機器的FTP但不允許訪問WWW,C機器沒有任何限制。

vlan 10

vlan 20

vlan 30

int e1/0/5

port access vlan 10

int e1/0/10

port access vlan 20

int e1/0/15

port access vlan 30

int vlan 10

ip address 192.168.10.1 255.255.255.0

undo sh

int vlan 20

ip address 192.168.20.1 255.255.255.0

int vlan 30

ip address 192.168.30.1 255.255.255.0

acl number 3001

rule 1 deny tcp source 192.168.30.0 0.0.0.255 destination 192.168.10.0 0.0.0.255 destination-port eq www

int e1/0/15

packet-filter inbound ip-group 3001 rule 1

進口

  十、NAT地址轉換(單一靜態一對一地址轉換)

R1:

sys

sysname R1

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.1.1.1 255.255.255.0

R2:

sys

sysname R2

int e2/0

ip address 192.1.1.2 255.255.255.0

int e1/0

ip address 10.80.1.1 255.255.255.0

回到R1:

nat static 192.168.3.1 192.1.1.1

int e2/0

nat outbound static

ip route 0.0.0.0 0.0.0.0 192.1.1.2

  十一、端口配置

[Quidway-Ethernet1/0/1]duplex {half|full|auto} 配置端口工作狀態

[Quidway-Ethernet1/0/1]speed {10|100|auto} 配置端口工作速率

[Quidway-Ethernet1/0/1]flow-control 配置端口流控

[Quidway-Ethernet1/0/1]mdi {across|auto|normal} 配置端口平接扭接

[Quidway-Ethernet1/0/1]port link-type {trunk|access|hybrid} 設置端口工作模式

[Quidway-Ethernet1/0/1]undo shutdown 激活端口

[Quidway-Ethernet1/0/2]quit 退出系統視圖

  十二、鏈路聚合配置

[DeviceA] link-aggregation group 1 mode manual 創建手工聚合組1

[Qw_A] interface ethernet 1/0/1 將以太網端口Ethernet1/0/1加入聚合組1

[Qw_A-Ethernet1/0/1] port link-aggregation group 1

[Qw_A-Ethernet1/0/1] interface ethernet 1/0/2 將以太網端口Ethernet1/0/1加入聚合組1

[Qw_A-Ethernet1/0/2] port link-aggregation group 1

[Qw_A] link-aggregation group 1 service-type tunnel # 在手工聚合組的基礎上創建

tunnel業務環回組。

[Qw_A] interface ethernet 1/0/1 將以太網端口Ethernet1/0/1加入業務環回組。

[Qw_A-Ethernet1/0/1] undo stp

[Qw_A-Ethernet1/0/1] port link-aggregation group 1

  十三、端口鏡像

[Quidway]monitor-port  指定鏡像端口

[Quidway]port mirror    指定被鏡像端口

[Quidway]port mirror int_list observing-port int_type int_num 指定鏡像和被鏡像

  十四、STP配置

[Quidway]stp {enable|disable} 設置生成樹,默認關閉

[Quidway]stp mode rstp 設置生成樹模式為rstp

[Quidway]stp priority 8192     設置交換機的優先級

[Quidway]stp root {primary|secondary}    設置為根或根的備份

[Quidway-Ethernet0/1]stp cost 200     設置交換機端口的花費

MSTP配置:

# 配置MST為info,MSTP修訂級別為1,VLAN映射關系為VLAN2~VLAN10映射到生成樹實例1上,VLAN20~VLAN30映射生成樹實例2上。

system-view

[Sysname] stp region-configuration

[Sysname-mst-region] region-name info

[Sysname-mst-region] instance 1 vlan 2 to 10

[Sysname-mst-region] instance 2 vlan 20 to 30

[Sysname-mst-region] revision-level 1

[Sysname-mst-region] active region-configuration

  十五、MAC地址表的操作

① 在系統視圖下添加MAC地址表項

[Quidway]mac-address { static | dynamic | blackhole } mac-address interface interface-type interface-number vlan vlan-id ;添加MAC地址表項

在添加MAC地址表項時,命令中interface參數指定的端口必須屬于vlan參數指定的VLAN,否則將添加失敗。

如果vlan參數指定的VLAN是動態VLAN,在添加靜態MAC地址之后,會自動變為靜態VLAN。

② 在以太網端口視圖下添加MAC地址表項

[Quidway-Ethernet1/0/2]mac-address { static | dynamic | blackhole } mac-address vlan vlan-id

在添加MAC地址表項時,當前的端口必須屬于命令中vlan參數指定的VLAN,否則將添加失敗;

如果vlan參數指定的VLAN是動態VLAN,在添加靜態MAC地址之后,會自動變為靜態VLAN。

[Quidway]mac-address timer { aging age | no-aging } 設置MAC地址表項的老化時間

注意:缺省情況下,MAC地址表項的老化時間為300秒,使用參數no-aging時表示不對MAC地址表項進行老化。

③ MAC地址老化時間的配置對所有端口都生效,但地址老化功能只對動態的(學習到的或者用戶配置可老化的)MAC地址表項起作用。

[Quidway-Ethernet1/0/2]mac-address max-mac-count count 設置端口最多可以學習到的MAC地址數量;

注意:缺省情況下,沒有配置對端口學習MAC地址數量的限制。反之,如果端口啟動了MAC地址認證和端口安全功能,則不能配置該端口的最大MAC地址學習個數。

[Quidway-Ethernet1/0/2]port-mac start-mac-address 配置以太網端口MAC地址的起始值

在缺省情況下,E126/E126A交換機的以太網端口是沒有配置MAC地址的,因此當交換機在發送二層協議報文(例如STP)時,由于無法取用發送端口的MAC地址,將使用該協議預置的MAC地址作為源地址填充到報文中進行發送。在實際組網中,由于多臺設備都使用相同的源MAC地址發送二層協議報文,會造成在某臺設備的不同端口學習到相同MAC地址的情況,可能會對MAC地址表的維護產生影響。

[Quidway]display mac-address 顯示地址表信息

[Quidway]display mac-address aging-time 顯示地址表動態表項的老化時間

[Quidway]display port-mac 顯示用戶配置的以太網端口MAC地址的起始值

  十六、GP配置

[Qw_A] gvrp 開啟全局GVRP

[Qw_A-Ethernet1/0/1] gvrp 在以太網端口Ethernet1/0/1上開啟GVRP

[Qw_A-Ethernet1/0/1] gvrp registration { fixed | forbidden | normal }

配置GVRP端口注冊模式 ,缺省為normal。

[Qw_A] display garp statistics [ interface interface-list ] 顯示GARP統計信息

[Qw_A] display garp timer [ interface interface-list ] 顯示GARP定時器的值

[Qw_A] display gvrp statistics [ interface interface-list ] 顯示GVRP統計信息

[Qw_A] display gvrp status 顯示GVRP的全局狀態信息

[Qw_A] display gvrp statusreset garp statistics [ interface interface-list ] 清除GARP統計

  十七、DLDP配置

[Qw_A] interface gigabitethernet 1/1/1

[Qw_A-GigabitEthernet1/1/1] duplex full 配置端口工作在強制全雙工模式

[Qw_A-GigabitEthernet1/1/1] speed 1000 速率為1000Mbits/s

[Qw_A] dldp enable 全局開啟DLDP。

[Qw_A] dldp interval 15 設置發送DLDP報文的時間間隔為15秒。

[Qw_A] dldp work-mode { enhance | normal }

配置DLDP協議的工作模式為加強模式。 缺省為normal。

[Qw_A] dldp unidirectional-shutdown { auto | manual }

配置DLDP單向鏈路操作模式為自動模式。 缺省為auto

Qw_A] display dldp 1 查看DLDP狀態。

① 當光纖交叉連接時,可能有兩個或三個端口處于Disable狀態,剩余端口處于Inactive狀態。

② 當光纖一端連接正確,一端未連接時:

如果DLDP的工作模式為normal,則有收光的一端處于Advertisement狀態,沒有收光的一端處于Inactive狀態。

如果DLDP的工作模式為enhance,則有收光的一端處于Disable狀態,沒有收光的一端處于Inactive狀態。

③ dldp reset命令在全局下可以重置所有端口的DLDP狀態,在接口下可以充值該端口的DLDP狀態

  十八、端口隔離配置

① 通過端口隔離特性,用戶可以將需要進行控制的端口加入到一個隔離組中,實現隔離組中的端口之間二層、三層數據的隔離,既增強了網絡的安全性,也為用戶提供了靈活的組網方案。

[Sysname] interface ethernet1/0/2 將以太網端口Ethernet1/0/2加入隔離組。

[Sysname-Ethernet1/0/2] port isolate

[Sysname] display isolate port 顯示隔離組中的端口信息

② 配置隔離組后,只有隔離組內各個端口之間的報文不能互通,隔離組內端口與隔離組外端口以及隔離組外端口之間的通信不會受到影響。

當前位置:主頁 > 網絡營銷 > 華為交換機配置命令大全,先收藏起來留著以后用

搜索
網站分類
標簽列表
?

15361814538

mg热血羽毛球网站 九州城娱乐十年信誉 多宝娱乐靠谱吗 红马计划官网安卓系统 北京快乐8上中下稳赚 火龙果计划官网 江西11选5精准计划 11选五软件下载 快3中奖绝招最新126 竞彩足彩 北京pk10官方正品网站 澳洲幸运五APP pk106码倍投方案 北京pk10走势图网易 上海时时